日々更新中です!

AWS EC2でWordPressをインストールしたらPHPバージョンエラー出た

  • URLをコピーしました!
悩んでいる男の子

EC2でWordPressをインストールしたらPHPのエラーが出ちゃった。。
解消法が分からないから教えてほしいんだけど。。

こんな悩みを解決します。

  • 本記事の内容
  • PHPエラーの具体的な内容
  • PHPエラーの解消方法
  • 本記事の執筆者
プロフィール
いずみん(どこの写真だよ)
  • 元エンジニア(歴7年)、資格保有数約20個(IT系以外も含む)
  • 物販月利50万円⇒脱サラ
  • 物販、システム開発、アフィリエイト、プログラミング、投資をやっています。
  • 物販は彼女と楽しみながらやっています!

今回は、EC2でWordPressをインストールする際に出たPHPバージョンエラーの解消方法を解説します 。

いずみん

すぐ読み終わるので、是非最後まで読んでみてください!

目次

エラー内容

Your server is running PHP version 5.4.16 but WordPress 5.3.2 requires at least 5.6.20.

EC2でWordPressをインストールすると、上記のようなエラーが発生しました。

エラー内容は、「WordPressに必要なPHPバージョンよりも古い」ですね。

エラー解消方法

sudo yum remove php-*

まず、PHP関連のパッケージを全削除します。

依存パッケージも削除されます。

sudo wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

epel-release-latest-7.noarch.rpm」を取得します。

sudo rpm -ivh epel-release-latest-7.noarch.rpm

epel-release-latest-7.noarch.rpm」をインストールします。

sudo yum install -y http://rpms.famillecollet.com/enterprise/remi-release-7.rpm

remiをインストールします。

sudo yum-config-manager --enable remi-php72

remi-php72を有効化します。

sudo ln -s /usr/bin/php72 /usr/bin/php

シンボリックリンクを作成します。

sudo yum install php-mysql php-mbstring php-gd php-devel

php関連パッケージをインストールします。

Apacheを再起動したら完了です。

続いて変なエラー出たら、、

sudo yum install php72-php-mysqlnd php72-php-mbstring php72-php-gd

php関連パッケージをバージョン指定で再インストールします。

Apacheを再起動したら完了です。

まとめ

今回は、EC2でWordPressをインストールする際に出たPHPバージョンエラーの解消方法を解説しました 。

ネットでググると皆手順が違っていて大変でした。。

ではまた!

まとめ
  • EC2でWordPressをインストールする際にエラーが出たら、PHPのバージョンが古い可能性が高い。
  • 自由な生き方がしたいなら!

自由な生き方をするためには、稼ぐスキルを身に付けなければなりません。

当サイト「リバトレ」では稼ぐスキルに関する情報を日々発信しているので、興味のあるものから見て頂ければ嬉しいです。

この記事が気に入ったら
いいね または フォローしてね!

シェアするんやで!
  • URLをコピーしました!
  • URLをコピーしました!

この記事を書いた人

いずみんのアバター いずみん 自由大好きおじ

自由大好きおじ | 物販月利50万達成⇨脱サラ | 物販(アパレルせどり)・アフィリエイト・プログラミング・投資に関する情報を発信中 | 元エンジニア | 保有資格約20個

コメント

コメントする

目次
閉じる